I’m Sorry Your Browser Is Not Supported: Please Make Sure You Are Using Mosaic

Jun 12 2011

The other day I was using  an ordering system for a very large seed/plant company and received this message

Am I going to have to dust off my old copy of Mosaic? Looks like I am going to have to use my time machine and go back to 2008 and reinstall IE from 2008 except for one thing, I’m on a Mac and that’s not supported at all.  A company that does hundreds of millions in sales, spends tens if not hundreds of thousands on a system to allow me to order and research online, and they wipe out the entire process by not having anyone with a modern day browser able to use it.  Gotta love big business.  They have no idea that the money they spend to keep it up to date would be more than paid for by the savings in salespeople and increased orders.

Share This

About the author

Outsmarting the Dumb, Outworking the Smart

View all articles by ShaneCultra

1 comment

  1. theo

    Wow, how blind are these people ?

    That some stuff is not displayed okay but that you cannot complete an order !

    Opera is my favorite browser and that some stuff doesn’t work okay.. But Chrome and Firefox… Firefox is used ALOT. Oh well…

Comments are closed.